terça-feira, 5 de julho de 2016

HTML 5 - Safari does not suport "required" - Safari não suporta o "required"

Safari não aceita o "required" do HTML 5.

Para isso usar o código jQuery abaixo (posicionar depois do jquery.js ou jquery.min.js):

$("form").submit(function(e) {

    var ref = $(this).find("[required]");

    $(ref).each(function(){
        if ( $(this).val() == '' )
        {
            alert("Required field should not be blank.");

            $(this).focus();

            e.preventDefault();
            return false;
        }
    });  return true;
});
 

Nenhum comentário:

Postar um comentário